First real world structure: H-Bar

In this tutorial, you will how to draw polygons, alignment markers, and how to place them in the structure. It also gives an idea on how the smile2 user interface and the navigation in the document view works.

During this tutorial, we want to draw a simple structure that can be used for 4-point measurements or Hall resistance measurements, a so-called “H-Bar” structure:

_images/struct-h1.png

The final structure

Preparing

Before you start drawing, do the following:

_images/tut_hall_uimode.png
  • Create a new document by pressing Ctrl+N, by choosing File ‣ New form the main menu, or by using the new_icon tool button in the main toolbar.
  • Since we want to start with the small inner part, set the write filed size to 100 (µm) in the attribute editor, an press Home (or Pos1) key to focus the new write field.
  • The smallest width of our element is 5 µm. Therefore, we use this value for grid snapping. Set the grid snapping value to 5.
_images/gs_loc.png

Grid snappig can be enabled and adjusted in the main toolbar.

Drawing the H-Bar

  • Coose the create polygon tool add_polygon_m form the button shelf or from the main menu: Create ‣ Polygon Tool.

  • Move the mouse to a position of approximately -80, 5.

    Note

    The coordinates of the current mouse position are displayed in the status bar of smile2.

    _images/tut_hall_coords.png
  • Click with the left mouse button (LMB) to add the first point.

  • Move on to the next position and click when satisfied.

  • When reaching the last position press the ENTER key to finish the polygon.

_images/tut_hall_poly1.png

Hint

The Creating Objects chapter, explains in detail how the object creation tools work in smile2.

This part as Screencast

Part 1 of the tutorial: Preparing and Drawing the H-Bar

Drawing the contacts and pads

Organizing Layers

As next, we want to rename the current layer and create a new layer for the leads/pads. To do this, do the following.

  • Move the mouse over the “Initial Layer” entry in the layer editor, and doublecklick onto it. Now the name of the layer can be changed. Call it “H Bar”.

    _images/tut_hall_layer1.png
  • Click on the New Layer new_layer tool button in the the layer editor tool bar (or from the layer menu in the layer editor window). A second “Unnamed layer” appears. Rename it to “Contacts and Pads”.

Changing the write filed size

Since the contacts and pads will exceed the current write field, we want to increase it.

  • Set the write filed size to 1000 in the Document Settings sheet of the attribute editor.

Create the first voltage pad

  • Make sure the new layer Contact Pads ist selected in the layer editor.

  • Set the grid snapping value to 20.

  • Click-drag on the horizontal ruler to add a guide line. Place it to 240.

  • Do the same on a vertical ruler to add a horizontal guide line to -40.

  • Activate the Create Polygon Tool add_polygon_m and use the grid lines to draw the first pad:

    _images/tut_hall_pad1.png

    Right now, it is not important to be precise on the interface with the H-bar. We will adjust theese points in the next step. When done, press ENTER to finish the polygon.

  • Set the grid snapping value to 5.

  • Activate the move tool move_tool by pressing M.

  • Click on the newly created object to select it.

  • Position the mouse roughly ower the interface between pad and H-bar and use the mouse wheel to zoom in.

  • Activate the point selection mode with the pt_sel action in the main toolbar.

  • Click- or drag-select the points near the H-Bar and adjust them (one after on other).

    _images/tut_hall_pad2.png

    Hint

    Choose the x-ray xray display mode in the document view toolbar, in order to see the overlap.

  • Once satisfied, change back to the object selection mode with the obj_sel action in the main toolbar.

Create the first current pad

  • Change the grid snapping to 10 µm

  • Add new guide lines to:

    • Horizontally: 180 and -180
    • Vertically: -180, -130, and -40

    by click-dragging on the vertical/horizontal rulers.

  • Next, activate the Create Polygon Tool add_polygon_m and draw the lead. Again you do not need to be precise in the inner part.

    _images/tut_hall_poly3.png
  • When finisched change the grid snapping back to 5 µm. Select the new polygon and change to point selection mode pt_sel.

  • Adjust the points near the contact interface to match (and overlap) the left H-bar current lead. When finished, your structure should look like this:

    _images/tut_hall_2nd_pad_done.png

Duplicate the pads

  • If still in point selection mode, change back to object selection mode obj_sel.

  • Select the voltage pad by clicking on it with the left mouse button while the Shift key is held down.

  • With both objects selected, press Ctrl+D to duplicate the pad.

  • With the duplicated objects still selected, choose from the main menu: Modify ‣ Mirror Selection ‣ Mirror Horizontally.

    _images/tut_hall_pad_mirror1.png
  • As next select only both “voltage leads” (either by click-dragging a rectangle around both objects or by kliking on the unselected object by holding the Shift key pressed).

  • Once both “voltage lead” objects are selected, choose from the main menu: Modify ‣ Mirror Selection ‣ Mirror Vertically.

    _images/tut_hall_pad_mirror2.png
  • Basically we’re done with the pads, However, we want to rename the pads to something more descriptive. To do this, double-click the entry you want to rename in outliner and change the names.

    _images/tut_hall_pad_names.png

Now the structure looks already almost finished. The only still missing elements are markers for alignment (since the H-bar and the pads need to be exposed in two different steps).

This part as Screencast

Part 2 of the tutorial: Drawing the contacts and pads


Creating alignment markers

This part demonstrates, how to create geometry and alignment markers. These markers are used later to align the structure.

  • Again, reduce the write field to 100 µm and focus the view to it (with the Home key).

  • Next, create a new layer in the layer editor, rename it to “Markers”, and select it. You can also want to change the color, if you do not like the default color.

  • Now, it’s time to create the marker geometry. For this we use the Create a regular polygon (createRegularPoly) command. To do this, choose from the main menu: Create ‣ Regular Polygon. You can specify the “correct” settings now or edit them after creation. We do the later, so do not adjust the values for now. Simply go with the defaults (or currently set values) and hit Execute & Close. The following object has been created (right image) from the default settings (left image):

    _images/tut_hall_star_cmd.png
  • This is not what we actually want. We will now adjust the properties of the geometry generator, to match a “star”:

    • Select the newly created object.
    • In the attribute editor: choose the **Construction History details* property sheet.
    • Navigate to the RectangleNode 1. Here, the settings of the regular polygon node can be adjusted. Use the following values:
    _images/tut_hall_star1.png
  • Now, move the “star” object to -60,40 (whith move tool or by editing the Translation values in the Transform sheet of the attribute editor). You should also rename it to eg. “PM1” (either in attribute editor or in the outliner).

_images/tut_hall_star2.png
  • As next, we’re going to create the alignment marker. To keep this marker in the center of our just created “star” alignment object, we want it to be a child of this object. Before creating the marker, make sure the just created “star” is selected. Now, choose (from the main menu): Create ‣ Marker to create the position marker.

    Note

    If you take a look to the outliner, you notice, that “Marker1” is a child of “PM1”. This is so, because curing creation of the marker, “PM1” was selected. Alternatively, if there is no selection during the creation of a marker, it is placed as a “root” object and it can be placed a child of an object later (eg. with drag-and-drop in the outliner or with the parent command. The following image shows the object (with the position marker) and the relevant part in the outliner:

    _images/tut_hall_star3.png
  • For the other marker objects, we use Duplicate Special to create copies with “linked” geometry. This has the advantage, that we can modify the size and appearance of the marker object later. Do the following:

    • Select the “PM1” object (the “star” object, not the position marker child).
    • From the main menu select Edit ‣ Duplicate Special ‣ Array Duplicate (duplicate_b_s).
    • In the command settings dialog, use the following settings:
    _images/tut_hall_star_cpy.png

    (left) Settings for the duplicate array command. (right) result, after the command execution.

    Beside the successive translation make also sure to set Copy with referenced inputs and Place in sources’ parent group.

    • Hit “Execute & Close”.

Basically that’s it. Your hall structure is ready to be exposed.

This part as Screencast

Part 3 of the tutorial: Creating alignment markers


Advanced: Linking the geometry of the pads together

In this part, the node editor is used to link the geometry of the contact pads together.

Note

This part is only available as screencast

This part as Screencast

Part 4 of the tutorial: Linking the geometry of the pads together